Using Netlogger for Logging Ham Radio Traffic Nets
Written By Daryl Stout, WX4QZ
This was prepared for the Net Mexico D-Star Net, but this can be used with
any amateur radio traffic nets. The file was last updated on Jan. 17, 2021. It is
a basic guide for setting up, and using Netlogger with nets. While there are
YouTube videos out there, many program authors, unfortunately, are far
more technically savvy, than most folks. So, that’s why I prepared this file.
I know there are numerous other logging programs available, and every Net
Control is free to choose whichever program(s) they desire. Thanks to Jeff,
VE6DV...Larry, NN4H...Paul, K9PTF...El, K4DJL, and Steve, KC9SIO, for
their advice and help with setup and use of Netlogger. Each of the hams noted
uses the program with their nets.
I don’t use Netlogger for anything besides nets; but, it can be used for other
things, such as contesting and/or contacts. The logs can be imported and/or
exported via CSV or ADIF files to eQSL and LoTW; or with delimited files
that can be viewed in a utility such as Windows Notepad. Note that you can’t
make adjustments to some of the settings in “standalone” mode.
Netlogger is a freeware program, used by several amateur radio operators for
logging traffic nets, contesting, etc...and versions are available for Windows,
Linux, and Mac.
This PDF file is a quick start guide to setting it up and using it. I’ve utilized
screenshots from some of the nets I’ve been on as a checkin, or as the Net
Control Station; plus a sample net checkin log that I created. The full log
screenshot from one net that I was going to use in this file was “too grainy”.
As a side note, the box in the middle of the top line on some of the screens is
with a utility called Display Viewer. It allows moving items between multiple
monitors, so you don’t have to cram everything onto one screen. There’s a
free version, but the registered version to allow use on multiple computers, is
worth the cost. It’s a lifetime registration, so when there are upgrades, there
are no new fees. Info is available at https://www.binaryfortress.com/support
The latest version of Netlogger can be found at http://www.netlogger.org –

the graphic that you will see is in the screenshot noted below. You can choose
to Download The Program, Contact Support, or Join The User Groups. A
display of current nets in progress with Netlogger is also shown on the main
page.

Click on the “down arrow” to get the program. Choose the version, and your
operating system...then enter your callsign, and an email address. Save the
link to your download area, then double click on it (or right click on it, and
click Install) to run the installation program.
You will need to accept the license agreement to proceed with the installation.
In short, if you don’t want to accept the agreement, you might as well stop
reading this file now.
It may take several minutes to download and install the program, depending
on the speed of your internet connection, and your computer’s CPU. In short,
you’ll need to be patient. However, DSL or broadband is far better than dialup internet, especially “if the meter is running”.
Once downloaded and installed, the first time you run it, it’ll ask for your
callsign and name. You can leave it blank, if you have multiple hams using the
setup on your computer. But, the creation of a profile is optional...and it will
show NONE if no profile is created.
Now, on to the basic operations...monitoring, creating, and running a net.

First, when you double click on Netlogger, the screenshot (noted below) will
display:

This screenshot was done at 0347 UTC on Dec. 20, 2020 (what the net time is
displayed in). I have included all windows on the screen. Since I am the “op”
(operator), and set up a profile for such, that’s why this is shown above.
Note that the “Contacts” window at the bottom I normally do NOT use, as it
automatically sets the checkin color to “Worked Station Manually”. As a
result, I am not covering this section of Netlogger in this file, and you won’t
see it in my screenshots. However, if you wish to use that option, you are free
to do so.
To Monitor A Net In Progress, choose “Select Net”, then click on the desired
net, and choose Monitor Net.

Below are the screenshots that you will see with the “Select Net” option. This
was taken around 0350 UTC Sunday, Dec. 20, 2020. The nets change during
the day of the week, and for the time of day.

You will see the Net Name, Frequency, Mode, Server, Net Control, Logger,
Band, Start Time, IM (Almost Instant Messenger, noted below) Enabled,
Update Interval, and Subscribers (those logged on).
At the bottom of the screen, you’ll see the status of the servers...the colors
indicate whether or not they’re available/online. You can adjust the time for
net polling as desired.

To monitor a net, click on the desired net, and click Monitor Net.
The program has an “Almost Instant Messenger” (AIM) window where you
can chat with those logged on...whether you are monitoring a net, or running
one. This can be Net Control, or others who are also monitoring the net.
To view these stations, click on View Monitors. You can uncheck the box if
you don’t want to see the “Offline” stations.
What this does is to allow chatting and other comments during the net, such
as providing links on net related topics, advising Net Control that they can’t

hear a certain station, or telling Net Control they need to be short time, or
they need to check out from the net.
Below is the screenshot from the Nov. 21, 2020 Multi-Mode Digital Voice Net,
on the QuadNet Array.

From the graphic above, stations are shown with their callsign or ID, name (if
provided), what version of Netlogger they’re running, their operating system
(W for Windows, M for Mac, and L for Linux), and their status, as follows:
! Lurking – They have connected to monitor the net, but are not yet “checked
in” (typed into Netlogger) by Net Control.
! Checked In – Net Control has logged them, or they have checked into the
net. They are online with Netlogger at the time.
! Checked Out – They were a courtesy checkin to the net, or have checked out
after one round (F5, noted below).

! Offline – They originally connected, but they’ve dropped the connection to
Netlogger; yet, they were still logged by Net Control.
Below is a screenshot during the Jan. 11, 2021 Hotspot, Raspberry Pi, SBC,
and Zum Spot Net on the QuadNet Array.

The text colors from the above window are as follows:
Gold: Comments from the current “operator” at your end.
Cyan: Status updates when a station logs on to, or off from Netlogger, plus
when logging is started or stopped.
White: Comments from other stations in the chat room.
Green: Usually with comments from other stations, a URL you can click on.
Obviously, be careful what URL’s you click on, and be sure your computer
virus protection software is current.

Messages are typed in the bottom window. It might take a minute after you
hit <ENTER> for the message to go across, depending on your internet speed.
To start a net, select “Create Net”, and you will see the screenshot that is
shown on the next page.
The net data includes the net name, server cluster (Netlogger, etc.), net
password (the net password and verify password must match), callsign of net
control, frequency, mode, and band. It’s helpful to enter the net frequency,
reflector, etc., so other stations will know where to find the net. Nets can be
run either on RF (HF/VHF/UHF), via “internet radio” (D-Star, DMR, CQ100,
etc.), or with various modes. You’ll enter the desired data for your particular
net. I used “The Food Net” that I do on the 3rd Saturday of each month.

Once you hit OK, the program changes from Standalone Mode to Logging
Mode. If you had entered data in error before you hit OK, you can change it
in logging mode (such as the net name, frequency, mode, band, and callsign
of the net control and logger), even while the net is in progress.
As for the password, the Net Manager can decide on a common password for
the net controls...or the Net Controls can use their own. Note that if the latter
option (individual passwords) are used, it’s advised to let the other net control
stations of what their chosen password is...so, if they need to take over with
logging or net control during the net, they can do so. For security reasons, the
password is not displayed. However, as noted above, if the system detects the
password doesn’t match, you’ll be shown an error message, and have to reenter the passwords.

The “net password” feature allows only authorized Net Controls to modify
the log. Otherwise, a “renegade ham” could muck up the log big time. If it’s a
shared net password, it should be easy for the net controls to remember, but
difficult for anyone else to guess.
If you are in “Monitoring” mode, if you click on “Start Logging”, you’ll be
asked for the “net password”. The original Net Control Station can upgrade
the status of a station to logger via the AIM client, or they can ignore a certain
station, such as SWL entries. Normally, on ham radio nets, you don’t want to
log “non-hams”.
WARNING!! Do NOT send the net password in the AIM Chat Window in
Netlogger, or on D-Rats. Otherwise, stations connecting to these will see it!!
Instead, send that via email, or a related messaging utility...but you want to be
sure that only the desired individuals know it.
A new set of “10 checkin slots” is added after the 9th, 19th, 29th, etc., checkin.
The net status colors in the screenshot later in this document are hard coded
(Net Control, Logger, VIP, Worked Station Manually, Worked Station Next,
Relay Station, Not Heard, Short Time, Courtesy Check, No Response, etc.).
Net controls can use as many, or as few of these desired with their setup.
Here’s a “sample net” checkin log.

The ones that I use (with the function keys, if applicable) are as follows – note
that with some nets, more than one entry may be in the status column – these
colors are “hard coded” within Netlogger, and can NOT be changed.
! Pink – Current station addressing the net. If Net Control is making changes
to the log, while a certain station is addressing the net; this color may “move
around”. This normally is not shown in my “screenshots”.
! Dark Cyan – Operator (you). You likely entered your callsign when you ran
the program for the first time. If this is on a net that you’re running (if you’ve
noted yourself as Logger and/or Net Control), you won’t see this color. This is
noted as (op) in the status column...especially if you check on other nets to
monitor them.
If you “recover the log” after the net has been closed, this status won’t show
up. But, the Netlogger servers act as a backup, for you to reconstruct the logs
for a particular net, if your computer crashes after the net was closed by Net
Control.
The Net Official Status variable, noted below, is set by moving the cursor to
the “status” column, and “right clicking” the mouse. From there, look for the
“Net Official Status” option. Then, choose either Net Control, Logger, Relay,
or VIP Status...all noted below.
! Dark Purple – Net Control. This is set by the Net Official Status variable.
This is noted as (nc) in the status column. If Net Control is doing both Net
Control and Logging, only this color will show up.
! Light Purple – Logger. This is set by the Net Official Status variable. This is
noted as (log) in the status column. If another station is Net Control, and you
are logging, you’ll see this color...and the Net Control color, noted above. If
Net Control is also doing the logging, this color won’t be shown, but (log) will
still show up in the status column.
! Dark Red – VIP Status. This is set by the Net Official Status variable. It can
be for those who are Net Control operators for other nets...or for officers for a
club or organization. This is noted as (vip) in the status column. To me, Net
Controls and officers deserve recognition; as many times, it’s a thankless job.

! F3 – Red Orange – It’s noted as “worked station manually” or if that station
has been “logged as a contact”. However, I’ve decided to use this entry for
stations who are Mobile or Portable, or even as a Special Event station, who is
also checking into the net. This is noted as (W) in the status column.
! White – Regular Checkin/Made Comments. You place whatever comments
you wish in the Remarks section, if desired. This can be the topic discussed if
they have traffic, which mode they logged on from, their status, etc. Unless
you have set up “club station information” for stations, the default display
will be “no club info”.
! Orange – Relay Station. This is set by the Net Official Status variable, and is
for a station who relayed in a certain station as a checkin...or they were
relayed in by another station. This is noted as (rel) in the status column; and
is done for “weak signal stations”, “on the fringe area” of the repeater, etc.
! F4 – Light Green – It’s noted as “worked station next”, but I’ve decided to
use that for stations with traffic for the net...so I can get to them first before
getting to other stations. This is noted as (n) in the status column. Sometimes,
stations with traffic, need to secure their station, after passing their traffic.
This can also be used if a station has traffic during a net, such as a net done in
a roundtable format.
! F5 – Gray – Courtesy Check, or for they checked out after 1 round (if multirounds on the net). This is noted as (c/o) in the status column. Some nets that I
do make only 1 pass through the log, and others have at least 2 rounds, and
sometimes more; but that’s at the discretion of Net Control.
! F6 – Yellow – Not Heard. This is noted as (n/h) in the status column. This
can also be used if the station had issues with their rig, Hotspot, Raspberry Pi,
ZoomSpot, or their internet connection. We can’t keep “Murphy” out of the
shack. In short, two words from the title of a cartoon from “The Ant And The
Aardvark”: Technology, Phooey!! (hi hi).
! F7 – Light Cyan – Short Time. This is for in and out stations. This is noted
as (u) in the status column (unavailable). I also use this for stations checking
in from a particular net’s Facebook group, from D-Rats, or via email. Not
everyone may have access to a radio for a net checkin...but, they’d still like to
get on the log as “a bean for the count”.

! F8 – Dark Green – No Response. This is after multiple calls for the stations
who were originally “Not Heard”. This is noted as (n/r) in the status column. I
usually do 2 calls, and if I don’t get a response, I mark them as such, and
move on.
! F9 – Clear the Status Entry. This is useful for switching from “Not Heard”
to “No Response”, or when they did show up for comments after all.
If you entered the wrong callsign, the command for “Clear Entry” will delete
the entire line. Again, you may use as many or as few of the options that are
noted above, as you so desire.
Net Control can enter whatever info/data they wish in the Remarks column
(club or organization membership, the mode that they used at checkin, their
status, net control for another net, club officer, net manager, mobile, portable,
short time, not heard, no response, etc.). As noted earlier, if nothing is typed
in the Remarks Section, unless you’ve set up the Club Information entries, it
will show up as “(no club info)”.
Several choices are under “Club Award Status”...which like the Net Official
Status, as noted above...is gotten to by moving the cursor to the “status”
column, then “right clicking” the mouse. The categories are military, first
responders (police, fire, paramedic), 18 wheel mobile (truck driver), clergy,
YL (female ham radio operator...although I guess you could use the same for
a married female ham radio operator (XYL)), museum ship, and QRP, among
others. For these, or for a Mobile or Portable Station, I note such in the
Remarks Column...and as noted above, I note them with the F3 (worked
station manually) command; as I wanted a different “color code”, anyway.
If The Checkin Order Suddenly Goes from “Sequential To Skewed”:
In moving the mouse around during the net, Net Control can accidentally
click on the top of a column, causing the order of checkins to get skewed. It
can be with the order of checkins, the name, location, city, etc. To get it back
to sequential, click the mouse above the # sign in the left hand column. You
may have to do it more than once, but it’ll restore things to sequential order.
Closing A Net:

Normally, when the net is in Logging Mode, there is a value in the timeout
column. Basically, if no data is entered within that time, the system will
automatically disconnect you. In short, failing to disconnect when the net is
done, is like leaving a party without bidding the host “adieu”, and it’s
considered rude.
However, it’s STRONGLY ADVISED that you click “Close Net” when the net
is done. Answer YES to confirm such...and this will also stop logging, close the
chat window, announce in the AIM window that the net is closed, remove the
net entry from the Netlogger website, and save the data to the Netlogger
servers, for “recovery mode”, noted below. If you don’t do this, you may get a
warning message from the System Administrators, for “improper logoff”, and
could be banned from future use of Netlogger, if these happen again.
Now, if you lose power and internet during a net, that’s one thing. If you have
a problem with power issues, consider getting a UPS (Uninterrupted Power
Supply) unit, or a generator. To keep the internet connection, you may want
an alternate device to your hard-lined internet, such as a Verizon Mi-Fi. But,
keep both connections “active”, so if one fails, you’ll still be “online”.
Once the net is closed, you can save the file via screenshots, or to a delimited
logfile (*.log), where it can be read via a utility such as Windows Notepad.
Recovering Checkins From A Previous Net Log:
If your computer crashes after you closed the net, before you got the chance
to save the log or screenshot to your computer, all is not lost. If you used the
Netlogger servers, you can choose View → Previous Nets. Then, select the
desired net, and tell the system to “Load Checkins”. That way, you don’t have
to try to reconstruct the entire net checkin log from memory!! You will need
to do this as soon as possible after the net has been closed.
There’s also an option in Netlogger, where you can click on a particular
station’s callsign, and it’ll bring up their profile on QRZ. To view the full
address information (including email), you will need to be “logged in” to
QRZ.
Screenshots:

When doing screenshots, you can minimize the top and bottom window, for 39
entries are on the screen. If you hide the taskbar, you can get 41 entries. The
total number of lines may vary, depending on your screen resolution. If there
are more than the max page entries, then more screenshots are needed.
However, for better readability, it’s best if you split the screenshots into
multiples of no more than 20 checkins.
If more than one screenshot image is needed, I use LibreOffice (although you
can choose to use OpenOffice or Microsoft Office), I “create a document” and
import the screenshot images, lining them up. Then, I can create a new
screenshot, if more than one image is needed; with the new one, being a
combination. That is the one I save and upload to a Facebook page, etc.
Edit → Preferences → check the desired boxes. Under Edit, you can also
choose from several options, such as:
! To clear, insert, or delete a row. This is helpful if you entered the wrong
callsign (fat finger syndrome).
I normally don’t enter non-amateur radio callsigns (such as SWL Listeners).
This is because I have no idea who they may be…and you don’t want SWL
listeners trying to checkin to a ham radio traffic net, where you have to have
a license beforehand. Besides, I like knowing who checked into the particular
net.
! You can choose fonts and colors, plus column heights.
! For contacts and checkins, you can add or remove the desired columns.
For the checkins, I use the number (#) of the checkin, their callsign, State,
Preferred Name, Remarks, City, State, Name, and Country. You can click on
the name of the column to sort the data in a different way, and also use the
mouse to make the columns as wide, or as narrow, as you desire. You can also
copy the data at the top of a column, and move it to where you’d like, with the
mouse.
By clicking on Edit → Checkins Table...or Edit → Contacts Table, look for
“Enable/Disable Columns”. You can check or uncheck which ones you desire.

At the bottom of the screen, with the contacts, you can modify those windows
under Edit → Contacts Table – and do the same as noted above with the
Checkins table.
As noted earlier in this file, I personally do NOT use the Contacts Table info
during the nets (that’s why in the “sample net screenshot”, you don’t see this
“other data”). To me, this data is used in “contesting mode”).
If you use the “contacts table”, and have stations logged from there, it may
automatically set their color in Netlogger to what I’ve chosen as “Mobile Or
Portable”. If you do enter a station in the contacts, they’ll ALWAYS show up
as the red orange for “Worked Station Manually”, with the W option in the
status column.
Setup → Accounts → For QRZ, eQSL, and LoTW.
You have to enter your login credentials (usually your callsign and password).
As long as you have ONE of these set up, this will work for you. I have QRZ
and eQSL, but not LoTW (Logbook Of The World). Note that you have to be
an ARRL Member to use LoTW. While I’m a Life Member of ARRL, I don’t
use LoTW...even though I got “a key” to use it at one time. Once you have
these configured, all you do is enter the callsign (uppercase or lowercase), and
data is automatically filled in for you.
If a call doesn’t show up, check the FCC ULS (for a station in the United
States or its territories), or a worldwide callsign server. Some countries have
it, where the operator has requested that his contact data be kept from view.
If their preferred name is different (and you have that window enabled), you
can modify that. As an example, my full name is Daryl J.D. Stout – J.D. was
my late father’s name, but I’ve always gone by “Daryl”. As a side note, I was
named after the motion picture director Daryl Zanick; while my brother was
named after actor Dana Andrews. However, he has no interest in ham radio,
or any of my other hobbies.
One of the nice features with Netlogger is that if you try to enter a callsign
that has already been entered, an asterisk will appear, with nothing else;
noting the entry is a duplicate...if you have set up Netlogger as such. However,
you can choose to allow duplicate entries under Function → Enable Duplicate

Entries...although in doing so, you get “a false total”. If you have “enable
duplicate entries” disabled, you could re-type the callsign at the bottom, to
note they have a recheck for the net. I did NOT note this in the sample net
checkin screenshot, noted earlier in this document.
For the screenshots, several utilities are available. I use the utility with the
IObit program software (https://www.iobit.com). While there are freeware
versions, you have to run updates manually. Yearly subscriptions for these are
available, and with some of the utilities, you can use that program on three (3)
separate computers at once. These utilities are mainly for Windows systems.
Once you have purchased a yearly subscription, you can choose to manually
install updates (after being notified of such), or have the program install the
updates automatically. At certain times, you can get these programs at special
discounted rates; and at the time of purchase, you can set up “auto renewal”,
to be charged to your credit or debit card.
Some of the programs are IObit Malware Fighter (with 3 virus protection
engines), Driver Booster (keeps all your system drivers up to date), Smart
Defrag (defragmenting hard drives or USB drives), Uninstaller (to remove
unwanted programs), Advanced System Care (takes care of several options),
Start Menu 8 (makes the Windows Start Menu look like Windows 7 or 8
instead of Windows 10), and IObit Software Updater (updates current
programs, and allows you to install recommended new ones). These will work
with either 32-bit or 64-bit Windows systems.
There are many more options in Netlogger that I’ve not detailed, but this
should get you started, in regards to running nets. If you have any questions,
please email me at wx4qz@arrl.net – and I will try to assist you. Please be
patient on a reply...which will come from wx1der@gmail.com (although you
can use that address – the wx4qz@arrl.net is a forwarder, so if Gmail ever
shuts down (highly unlikely), I just have to change one variable, and not try
to notify everyone in the address book). As a side note, Gmail requires at least
6 characters in an email prefix, and with so much tied up in the email address
already, I didn’t see any reason to create a new email.
My ham radio bio is now at https://www.theweatherwonder.com/elk.htm –
that page also has links to spreadsheets of selected D-Star, D-Rats, and
Echolink Nets, in the 4 main US Time Zones (Eastern, Central, Mountain,

and Pacific), plus several other PDF files related to amateur radio. By moving
the bio there, it’s easier for me to edit and upload. A PDF Reader is required
for the PDF files; and Microsoft Excel or Office, LibreOffice, or OpenOffice is
required for the spreadsheet files.
For my full bio, please go to https://www.theweatherwonder.com/bio.htm
Daryl Stout, WX4QZ, Little Rock, Arkansas
I’m Net Control for these nets during the week, when using Netlogger:
Sunday: QCWA Net, the QuadNet Array (https://openquad.net), 5pm
Eastern, 4pm Central, 3pm Mountain, 2pm Pacific. Note that membership in
the QCWA is not required to checkin to the net.
Monday: Hotspot, Raspberry Pi, SBC, Zum Net, the QuadNet Array
(https://openquad.net), 10pm Eastern, 9pm Central, 8pm Mountain, 7pm
Pacific.
Tuesday: Arklatex D-Star Net, Reflector 48 B (with Reflector 73 B as a
backup), 8:30pm Eastern, 7:30pm Central, 6:30pm Mountain, 5:30pm
Pacific.
2nd Thursday: New Mexico D-Star Net, Reflector 55A (with Reflector 72 A as a
backup), 10pm Eastern, 9pm Central, 8pm Mountain, 7pm Pacific.
Friday: Trains Net, the QuadNet Array (https://openquad.net), 8pm Eastern,
7pm Central, 6pm Mountain, 5pm Pacific.
3rd Saturday: Food Net, the QuadNet Array (https://openquad.net), 9pm
Eastern, 8pm Central, 7pm Mountain, 6pm Pacific.
With these nets, when I’m running them, early checkins are started at least 1
hour prior to the actual net start time. However, while I will give plenty of
time for stations to checkin, I’m not going to wait forever for a station to show
up. So, once checkins “dry up”, and I get no response to a “last call”, then I
will shut the net down.
Sorry for any inconvenience...your understanding is appreciated.

